WinPK Filter and VMWare

Home Forums Discussions Support Portal WinPK Filter and VMWare

This topic contains 6 replies, has 3 voices, and was last updated by  mwb1100 4 years, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5377

    libzhark
    Participant

    I am seeing a bug in the WinPK filter driver which affects how VMware bridges network adapters. In a windows 7 64-bit vmware image, Windows cannot obtain an IP address from the VMware bridged adapter and constantly resets itself.
    To replicate this bug:

      Set the VMware network settings to bridge to an adapter where there is Internetaccess.

      Run the Windows 7 VM

    Expected results:

      Windows 7 is able to obtain an IP address and connect to the Internet

    Actual Results:

      Windows cannot obtain an IP address from the VMware bridged adapter and constantly resets itself

    I would like to know if this a known issue or if there is a solution to this?

    #7086

    Vadim Smirnov
    Moderator

    Could you provide more details in regards to network configuration. Who assigns IP address to your internet connected network adapter? By other words, is Internet network adapter connected directly to ISP or through the router/NAT wchich assigns IP addresses over DHCP? Does it changes anything if you manually assign an IP address to network adapter inside VNWare OS?

    #7087

    libzhark
    Participant

    The network adapter is connected to an local network with a router that assigns IP addresses via DHCP. The adapter inside of the VMware virtual machine is not able to obtain an IP address via the bridged connection to the local LAN. Without the WinPK filter installed on the host machine, the VMware virtual machine is able to obtain an IP address from the router and has full local network/Internet connectivity.

    I’ll test with static addresses and get back to you on the results.

    #7088

    Vadim Smirnov
    Moderator

    I had not heard about such issues before, however I think it can be related to filter layering with VMWare bridging driver which is also probably implemented as NDIS LWF or NDIS IM driver. In order to support virtual network adapter with its own MAC address VMWare bridging driver probably puts real hardware NIC into promiscuous mode and clone received packets to virtual NIC inside VMWare. Here you probably have a sort of conflict between filter drivers, when packets for virtual NIC MAC address are not delivered to VMWare driver. Could you try uninstall VMWare, reboot and reinstall while keeping Winpkfilter installed? It may change drivers layering and fix the issue.

    #7089

    Vadim Smirnov
    Moderator

    By the way, what version of VMWare are you using? In the neighbor thread of the forum we are discussing another example of VMWare behavior, although your problem were not reproduced.

    #7090

    libzhark
    Participant

    We are using VMware Player 5.0.0 build 812388. We are going to try all of your suggestions today (static ip, install order).

    #7091

    mwb1100
    Participant

    I was having problems with VMware bridged networking after the VirtNet adapter was installed and thought it might be related to the problem you’re seeing with the WinPK filter, but I’m not familiar with that software package, so I’m not sure. I hope that the steps I had to take to get bridged networking working might help you with the WinPK filter.

    I saw the problems with bridged networking on two machines (work and home), and I had to do one or both of the following to get it working with the VirtNet loopback adapter:

    – reconfigure the VMware Virtual Network using the “Virtual Network Editor”. If you are using VMware Workstation, you can open the editor using the “Edit/Virtual Network Editor…” menu item. My understanding is that with VMware Player the Virtual Network Editor might not be accessible via the menus or even installed by default. If you’re running VMware Player, you might need to extract the editor from the installation image. This article has some details on how to do that: http://bigsnowball.com/content/fixing-vmware-player-bridged-network

    Once you have opened the Virtual Network Editor, select VMnet0 (which is the default bridged virtual network) then change the “Bridged to:” option to the the appropriate physical network adapter the VM should be bridged to instead of the default “Automatic”.

    – the other problem I ran into on one of my machines (which really has nothing to do with the VirtNet adapter, but it caused me a lot of grief when I was trying to troubleshoot the VirtNet problem) was that it was running a rather aggressive firewall, Agnitum Outpost Firewall. To fix this problem, I followed the instructions on Agnitum’s “KB Article: VMware virtual machines fail to access the network. What is the problem?”: http://www.agnitum.com/support/kb/article.php?id=1000061

    I suspect that even if you’re running a different software firewall which is causing problems with bridged networking (you can usually test that by disabling the firewall entirely for a short period to see if the VM’s network starts functioning), the general instructions may help with configuration there as well, even if the specific steps are different.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.