Slow/Timeout while parallel browsing

Home Forums Discussions Support Portal Slow/Timeout while parallel browsing

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12671
    Deviboy
    Participant

    Hey folks,

    I use Wiresock for browsing with two browser ( 1 over WG, 1 over standard network ).

    I set up the Wiresock as windows service with the following command:wiresock-

    client.exe install -start-type 2 -config C:\Users\Test\Desktop\Rsee.conf -log-level none

    In AllowedApps i only added Firefox.

    While parallel browsing i get sometimes a timeout in on of the browsers, and also it loads very slow.

    I testet the Wireguard Conf without Wiresock and the speed is fine then.

    • Processor I6500T
    • Chrome – Standard / Firefox – Wiresock

    Do i have to add any tag in the setupcommand for using multiple cores of the processor? Or is there another possibility to improve the speed of parallel browsing.

    Thanks in advance!

    #12672
    Vadim Smirnov
    Keymaster

    Hmm, I’m running Wiresock in a similar setup, although Chrome uses a Wireguard tunnel and Firefox connects directly, and I’ve never noticed much slowdown. Of course, depending on the distance to your Wireguard server (and associated network latency), when you’re browsing the tunnel, websites usually don’t respond as quickly as they would with a direct connection, but that’s expected behavior.

    I would first try testing another Wireguard server, preferably one that you set up yourself and has enough CPU and network resources. Otherwise, other VPN clients may affect the performance of your tunnel in unpredictable ways, and a clean test will not be possible.

    Do i have to add any tag in the setupcommand for using multiple cores of the processor?

    The Wiresock client uses 4 worker threads (4 cores) to process packets, this design seems quite scalable.

     

    #12674
    Deviboy
    Participant

    Thanks for your reply 🙂

    I already checked another Endpoint, and this is exactly the same problem.

    Furthermore if i check these endpoints with the standard wireguard-app – they work very smoothly, so it shouldnot be an issue with the performance of the wg-servers.

     

    I just made a few speedtests with the browsers – it seems to be a problem with the download speed.

     

    The browser without wireguard routing: 1,5 Mbps Download / 56 Mbps Upload

    After deactivating Wiresock – around 950 Mbps Downlaod

     

    The browser with wireguard routing: 95 Mbps Download / 56 Mbps Upload

    Seems to be fine here.

     

    So it seems like – that they cant get the full performance at the same time  ( and should not be an issue of my internetconnection – while normal browsing they will just use some Mbps together.

    #12677
    Vadim Smirnov
    Keymaster

    I think the problem you are having is related to the MTU setting in your config file. Try reducing the MTU (for example, from the default 1420 to 1412 or even 1280) and see if there is a difference.

    Unlike the standard WireGuard client, WireSock does not support fragmented UDP frames and download performance may be degraded due to packet loss.

    #12678
    Deviboy
    Participant

    I changed the MTU from previous 1412 to 1280 now – but makes no difference /

    The allowed App Firefox through VPN seems to have a perfect speed while InternetExplorer which is not through Wireguard is more than slow.

    Here is a little demonstration:

    https://www.youtube.com/watch?v=sLcrcapdKmI

    May it be an issue with the network adapter? Using an “Intel AC 8265” atm.

    #12679
    Vadim Smirnov
    Keymaster

    As far as I can see, Firefox works great over VPN, while IE slows down. And I suspect that the problem may be related to DNS. Since you specified DNS in the Wireguard config file, all DNS requests (not only Firefox, but also IE) go to this server. Try removing DNS from the config and/or changing it to something like 8.8.8.8 to see if there is a difference.

    One more question, did you run the wiresock client as administrator?

    #12680
    Deviboy
    Participant

    Jop – Wiresock runs as admin and also on another machine as windows service.

    I changed the dns to 8.8.8.8 and also tried to delete it complete from the config, but it makes no difference in the speed.

    think it is a problem with the wifi connection. if i run my setup on a machine, connected with ethernetcable – i dont get this issues.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.