PPP & Dial-up Issue

Home Forums Discussions Support Portal PPP & Dial-up Issue

This topic contains 1 reply, has 2 voices, and was last updated by  Vadim Smirnov 7 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5301

    speedvoipok
    Participant

    Hi Guru:
    On my PC I have created PPPoE connection by RasPPPoE. At this time, I run listadapters sample and NDISWANIP adapter is active. But when I run passthrough sample, I can not find any packet flow from/to my PC nic. In order to verify issue further, open wireshark and see normal packet traffic with PPPoE header. From WinpkFilter specification, following text can be found:

    Supported connection types:
    WinpkFilter supports Dial-Up connections (Analog modem, ISDN modem), Ethernet (LAN and WLAN) connections, Cable/DSL modem using DHCP or “PPP over Ethernet” (EnterNet, RasPPPoE, WinPoET).

    So what is root cause of this issue? Maybe something wrong with sample source code.

    #6832

    Vadim Smirnov
    Moderator

    Try to run passthru sample on the same network interface for which you run wireshark and I think you will be able to get exactly the same capture.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.