Seeking Assistance with DNS Suffix Configuration in WireSock Client

Home Forums Discussions Support Seeking Assistance with DNS Suffix Configuration in WireSock Client


Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #12926

      Hi there!

      First of all, I want to express my gratitude for your amazing work on WireSock! I stumbled upon your project while trying to resolve an issue with the regular WireGuard client.

      I would like to use WireSock as a client to gain access to my work’s internal network. In order to access internal resources, I need to use the FQDN of resources (e.g., internalSite.firmName.lan) or configure a DNS suffix (firmName.lan) on the adapter to use short names, such as internalSite. In the regular WireGuard client, this can be achieved using the DNS option as shown below:

      PrivateKey = <secret=>
      Address = 10.xx.xx.xx/32
      DNS = 10.xx.xx.xx, firmName.lan

      I attempted to use a configuration from regular WireGuard client with the WireSock like this:

      wiresock-client.exe install -start-type 2 -config "C:\Users\l2a\Downloads\my.conf" -log-level none -lac

      However, the DNS suffix wasn’t added to the adapter. I tried adding it manually via the GUI from ncpa.cpl, but I encountered an error since there was no IP address assigned directly to the adapter. As a workaround, I used PowerShell:

      $Domain = 'firmName.lan'
      $Nic = Get-DnsClient | Where-Object -Property InterfaceAlias -Match "Local Area Connection"
      Foreach ($N in $Nic) {
      Set-DnsClient -ConnectionSpecificSuffix $Domain -InterfaceIndex $N.InterfaceIndex

      This method worked, but I believe it should function like the regular client. Is there a simpler way to make the DNS suffix work with WireSock? Or do you have plans to implement this feature in the future?

      Thank you for your time and consideration. Looking forward to your response!

      Best regards

      Vadim Smirnov

        Hi there!

        Firstly, I want to thank you for your kind words and appreciation of our work on WireSock! It’s always great to hear that our project is helpful to users like you. I understand that you are trying to use WireSock as a client to access your work’s internal network and need to configure a DNS suffix for the adapter.

        From the information you’ve provided, it seems like you’ve managed to find a workaround using PowerShell. While this method works for now, I can see how having a more seamless integration with WireSock would be beneficial. I’ll be sure to do some research and look into potential solutions or improvements to better support the DNS suffix configuration in WireSock. In particular, in instances where it is available (Windows 10 and later), SetInterfaceDnsSettings could potentially be utilized. For earlier versions of Windows, similar functionality may be achievable by manipulating the Windows registry.

        Again, thank you for your feedback and for sharing your experience with us. Your input is invaluable in helping us improve our project for all users.

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.