Failed to find a matching WinpkFilter interface.

Home Forums Discussions Support Failed to find a matching WinpkFilter interface.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #13522


      I i trying to use WireSock and finally replace my old TunSafe Windows clients with it.

      My setup is non-standard, since the PC that is running the VPN client has a software firewall installed on it (Kerio Control). This gave me headaches in the past as well when trying to install TunSafe.

      Kerio is installing its own network filter in order to do low level NAT etc. In the past i had to disable this filter under the TAP VPN network adapter to allow it to work but this is not the case with WireSock.

      I am constantly getting a “Failed to find a matching WinpkFilter interface for {xxxxxxxxxxx}” and tunnel failed to start. Windows is 8.1 and everything is working ok with TunSafe (granted i have to apply the trick).

      I tried with Virtual Netweork Adapter mode but this one does not even show up on network interfaces.

      Any ideas?

      Vadim Smirnov

        It appears that there is a software conflict with Kerio. Could you please provide more detailed instructions on the setup needed for the test VM to replicate this issue?


          Sure here are the steps to reproduce:

          1. Install Windows 8.1 Pro on a VM

          2. Download and install Kerio Control with Windows support.

          (This is the latest version that supported the Windows platform)

          3. Install Kerio with their inbuilt VPN disabled, everything else should be left at defaults. (there is no need to configure anything since we only need Kerio to install its own network filters)

          4. Download WireSock and WireSockUI and use any wireguard .conf file.

          I just re-did this on the fly and got exactly the same error.

          Let me know if i can be of more help.


            I did some further investigations.

            I came up with some very interesting results:

            On a VM with the Kerio Control installed, a restart is required after installing WireSock and then everything is working (i do not even need to disable the Kerio Filter in the adapter options).

            On a VM without Kerio Control, a restart is not required after installing WireSock.

            So essentially my issue is resolved and i am sorry for not trying a simple restart prior to posting, but i was used to WireSock NOT needing a system restart post installation on all my other machines which obviously did not have Kerio Control installed.

            Thank you for your time and work.


              I spoke too soon 🙂

              I still have to disable the Kerio Control Filter from the WireSock virtual adapter after the reboot and use the Virtual Adapter option, otherwise outgoing traffic is working but incoming is not.

              It seems to be working fine tho with this combination of settings and considering that TunSafe is slow and old i am pleased.

              Vadim Smirnov

                I’m sorry for the delayed response, just got some spare time and returned to this topic to check the required setup. I’m glad that you were able to find the combination which resolves the issue. The after install reboot is probably can be explained that Kerio uses the NDIS filter driver similar to the one utilized by wiresock and network stack can’t rebind dynamically without a reboot. If my assumptions are correct the conflict with Kerio probably can be also addressed by changing the order of NDIS filter drivers. Not sure if it’s worth spending time on this right now but if there will be more requests for compatibility with Kerio, then I will do the research.

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.