App filter not working

Home Forums Discussions Support App filter not working

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #13210
    arkmem
    Participant

      App versions:

      wiresock-vpn-client-x64-1.2.28.1

      WireSockUI-v0.1.3-AnyCPU

      Windows:

      Windows 10 LTSC 21H2 19044.3208

       

      1. The app tunnels everything and ignores anything in DisallowedApps.

      DisallowedApps = chromium

      Result: WhatismyIP in chromium shows that it’s still getting tunneled.

      2. In the configuration for the tunnel, I can’t put .exe or the file path under AllowedApps and DisallowedApps. The Save button on the bottom right becomes unclickable.

      Unsaveable

      DisallowedApps = chromium.exe

      DisallowedApps = C:\Program Files\Google\Chrome\Application\chrome.exe

      Saves (but doesn’t work)

      DisallowedApps = chromium

      Please tell me what I’m doing wrong.

      • This topic was modified 11 months ago by arkmem.
      #13212
      Vadim Smirnov
      Keymaster

        Could you kindly provide the complete configuration file, excluding any keys, for review? Please be aware that the configuration accepts only a single DisallowedApps parameter; however, it can contain a list of apps, separated by commas.

        #13213
        arkmem
        Participant

          This is what it looks like minus the IPs and keys.

          [Interface]
          Address =
          DNS = 1.1.1.1, 1.0.0.1
          PrivateKey =

          [Peer]
          PublicKey =
          PresharedKey =
          AllowedIPs = 0.0.0.0/0, ::/0
          Endpoint =
          PersistentKeepalive = 25

          AllowedApps = firefox
          DisallowedApps = waterfox,chromium

          When I try to edit the config using the GUI, it won’t let me save if I put a .exe or put the file path, I can only add to the disallowed list via the selector (bottom left “Processes…” button), and even then it doesn’t actually filter anything.

          Here’s a screenshot. Please note that I’ve tried to add the file path without quotes too and it’s the same result.

           

           

           

          • This reply was modified 10 months, 4 weeks ago by arkmem.
          • This reply was modified 10 months, 4 weeks ago by arkmem.
          #13216
          arkmem
          Participant

            I’ve also tried editing the conf file directly to forcefully add the file path and the filename.exe, and it still doesn’t filter. Pardon the double post, I can’t edit the previous post anymore.

            #13217
            Vadim Smirnov
            Keymaster

              I advise against using both AllowedApps and DisallowedApps in the same configuration file. When AllowedApps is used, it implies that only the traffic from specified apps will be forwarded over the tunnel. Conversely, using DisallowedApps means that all traffic, except from these designated apps, will be sent over the tunnel. Combining both parameters can complicate the logic and potentially cause ambiguity in the routing rules.

              Please avoid using quotation marks. The string specified in AllowedApps/DisallowedApps is divided by commas, and the resulting substrings are employed as matching patterns. If a pattern includes a backslash (\), it is treated as a complete pathname. Conversely, without a backslash, it is interpreted as a simple application name.

              #13219
              arkmem
              Participant

                Thank you for the advice about not using both filters. It works. Unfortunately, the issue with the file path and the .exe in the filter remains. Even simply adding chrome.exe results in the unsaveable state shown in the previous screenshot, with the red squiggly underline. Same with omitting quotation marks.

                Thankfully only using one filter works though, so I can work around the issue.

                Thanks again, cheers.

                #13220
                Vadim Smirnov
                Keymaster

                  I’m glad to hear that only using one filter seems to be a viable workaround for you. I understand the continued issues you’re experiencing with the file path and the .exe in the filter; indeed, this seems to be a limitation with WireSockUI.

                  In contrast, the CLI client does not have these issues, and you might find it more accommodating for your use case. I suggest giving it a try while we’re working on improvements to WireSockUI.

                  I will also try to allocate some time to look into improving WireSockUI, although I should note that my proficiency isn’t particularly strong in C#. Despite that, I’ll certainly do my best to address these issues and provide a better experience.

                  Thank you again for bringing this to my attention, and for your patience as we work on these improvements.

                  Cheers!

                  #13222
                  arkmem
                  Participant

                    Thank you for the tip about the CLI client, I’ll try it out. Good luck with your work on the program and godspeed!

                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.