WinPKFilter on Vista x64 OS Help

Home Forums Discussions Support Portal WinPKFilter on Vista x64 OS Help

This topic contains 2 replies, has 2 voices, and was last updated by  jackie.poon@wdc.com 8 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5232

    jackie.poon@wdc.com
    Participant

    Hi,

    We are having a bit of trouble getting the WinPKFilter driver installed on Vista x64 OS.

    First we grabbed the driver files from the amd64 folder, test sign it by following this:
    http://msdn.microsoft.com/en-us/library/aa906285.aspx

    Proceed the installation with this as instructed on the help section:
    snetcfg.exe -v -l ndisrd.inf -m ndisrd_m.inf -c s -i nt_ndisrd

    The issue: it seems to be installed (still with the two red warning, that’s expected). From the Network properties, it seems that driver of WinPKFilter is installed with a checkbox. However when running the “filterstatus 0”, it returns:

    Driver not installed on this system of failed to load

    I would like to get some help from the community, with some step by step instruction on what or how to get this working under Vista x64. Thanks.

    #6702

    Vadim Smirnov
    Moderator

    The best available code signing walkthrough from Microsoft:

    http://www.microsoft.com/whdc/winlogo/drvsign/kmcs_walkthrough.mspx

    #6703

    jackie.poon@wdc.com
    Participant

    Followed the instructions and tried it twice with a clean OS and clean new test cert. No success. It doesn’t seems like it is the signature issue, it seems more the driver itself is not hooked or installed properly onto x64 Vista.

    Anyone here can offer help or hint? Thanks.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.