NAT server based on Internet Gateway Sample

Home Forums Discussions Support Portal NAT server based on Internet Gateway Sample

This topic contains 3 replies, has 2 voices, and was last updated by  siddappa 3 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5401

    siddappa
    Participant

    Hi,

    I have an application developed based on Internet Gateway sample and it does the job pretty well. But now i’m facing a strange issue, ie: When the client browses internet like watching some video stream or does anything heavy, the server gives delayed ping reply. Also the remote desktop from client to server starts disconnecting and sometime even the server LAN goes down. Have anyone else faced the same issue? Please do share the remedy if any for this issue.

    Regards,
    Siddappa

    #7163

    siddappa
    Participant

    To add up into the issue, adding multiple clients further slows down the ping response, to the point that i do not get any ping response from the server at all, it times out causing problems to other applications running on server.

    #7164

    Vadim Smirnov
    Moderator

    Internet Gateway is a sample application and does not pretend to be a full featured and performance optimized solution. Although there are ways to improve it.

    #7165

    siddappa
    Participant

    Thanks serpentFly, but the problem doesn’t seem to be on Win Xp, but only occurs in Win 7 and beyond. Does it got to do anything with driver? i’m using 3.0.8.1 version ndisapi driver.

    Also what i noticed in Win7 was the SendARP() call in tunnel mode having client IP as parameter would actually fail when called from StarNat(). To resolve this problem i added a filter to exclude In/Out of ARP packets and that seemed to solve the problem. But now we face the issue of packets getting dropped. Let me know is anything wrong in our apporach?

    Also it would help us to point out at better ways to optimize it further.

    Regards,
    Siddappa

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.