How to install Hook Driver

Home Forums Discussions Support Portal How to install Hook Driver

This topic contains 4 replies, has 3 voices, and was last updated by  esfahan 5 years, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5340

    yathindra
    Participant

    Hi,

    For installing IM driver of winpkfilter we use snetcfg command but for installing hook driver what’s the process. I have only sys file. How to install it? If i copy the sys file in system32 folder of windows is it enough or i need to do any thing? And what about windows 98 systems that is vxd file how to install it?
    Waiting for your reply.

    Thanking you,

    Regards,
    Yathindra.

    #6974

    Vadim Smirnov
    Moderator
    #6975

    yathindra
    Participant

    Hi,
    Thanks. If i just copied the sys file to system32 folder but not created the entries. In that case what will happen. Also tell me how to uninstall a hook driver. Waiting for your reply.

    Thanking you,

    Regards,
    Yathindra.

    #6976

    Vadim Smirnov
    Moderator

    If i just copied the sys file to system32 folder but not created the entries. In that case what will happen.

    Nothing, driuver won’t be loaded.

    Also tell me how to uninstall a hook driver.

    Remove registry key and driver binary from the system.

    #6977

    esfahan
    Participant

    opy ndisrd.sys to the WINNTSYSTEM32DRIVERS directory and create the following registry key in order to start helper driver on system boot:
    HKEY_LOCAL_MACHINESystemCurrentControlSetServicesNDISRD
    Under this key you should create the following values:
    “Type”=0x00000001 (REG_DWORD)
    “Group”=”Streams Drivers” (REG_SZ)
    “Start”=0x00000001 (REG_DWORD)
    “Error Control”=0x00000001 (REG_DWORD)

    i used this sample
    but not install and start this service ( win xp 32 bit )
    this manuola never note about installation ndisrd.inf !!!

    How to manual installation corect ?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.