Re: problem resolved

#6598

dvsing
Participant

I’m not sure if this was an SP1 issue or just a Vista issue in general, but I figured out a fix for it.

For a little background, I’m using Vista SP1 x64 which means that I have to use the F8 boot menu option to ‘disable driver signature enforcement’ in order to use the winpkfilter driver unsigned.

The problem was that after the login/password screen was displayed, the UI would freeze if I had booted using this F8 option with the WinPkFilter driver installed. Not using the F8 option to disable signature enforcement means that the WinPkFilter driver doesn’t get loaded and this was the only way I was able to log back into the system (by preventing the driver from loading).

The work-around is to boot into vista with diver signature enforcement enabled (normal boot) and open the Device Manager. Under the “Network adapters” tree you should see three “WAN Miniport (xxx) – WinpkFilter Miniport” devices: IP, IPv6, and Network Monitor. Right click each of these and disable them. This will not affect the usability of WinPkFilter.

My guess is that WinPkFilter is being installed such that it is binding to some adapters that are incompatible with it. This seems to fix the problem.

Also, as a side note, if you’re annoyed about having to hit F8 every time on boot to disable driver signature enforcement, there is an option: you can test-sign the driver yourself and enable the loading of test signed drivers. Instructions on doing this are available here:

http://www.rage3d.com/board/showthread.php?t=33920573

-Dan